PLEASE HELP... Error

Apr 25, 2011 at 5:00 AM

I have been following the Tutorial. the only difference between mine and the Tutorial, is the name Zombies instead of xTileGame. I get this when i try to Build Solution. If its not xTile.dll its xTile.Pipeline.dll.

Error 1 Error loading pipeline assembly "c:\users\aaron\documents\visual studio 2010\Projects\Zombies\xTile\xTile.dll". Zombies

Im not gettiong the tIDE Map Importer and tIDE Map Processor option in the content importer drop down. everthing it in place and being referanced correctly i assume. i ran a build befor starting step 6 and all was successful. What am i missing.

Coordinator
Apr 25, 2011 at 12:03 PM

Are you referencing the pipeline assembly from the content project? (not the main game project)

Apr 25, 2011 at 6:43 PM

yes

Apr 25, 2011 at 7:07 PM

the problem is the content pipeline does not exist. I have it in the Content References. BUt is doesnt give me access to anything tIDE stuff.

 

Coordinator
Apr 25, 2011 at 7:43 PM

Version 2.0.3 seems to be working fine at my end. Could you perhaps create a simple project to reproduce the problem and ZIP it over? or maybe ZIP your current project if its not too big?

Apr 26, 2011 at 4:17 PM

Yeah, ill do that

Aug 30, 2011 at 6:38 PM

I had the same problem, and fixed it by right-clicking on the two DLLs and 'unblocking' them (they were blocked because I'd downloaded them from the internet?).

Once I had the DLLs copied into a directory inside my project (I'm using Express, so no solution folders), 'unblocked', and correctly referenced, I could select the Importer and Processor properties of the map, and build the solution.

Anyway, perhaps that will help in this case.  I'm very new to Windows/.NET development, so still figuring it all out myself!

Jan 17, 2013 at 8:00 AM

I have the same problem, what was the solution?
What do you mean by "unblocking" I looked at the context-menu of the dlls in the explorer and visual express nothing. Also checked the properties tabs.

Jan 17, 2013 at 8:06 AM

I just found out how to unblock... I guess I am blind, cause I looked there about 10 times in the last 2 days...
Generally, every downloaded dll seems to be blocked.
To unblock a dll:

  1. right click on the dll in the explorer
  2. in the "General" tab (to first one) right down at the bottom - yet above ok, cancel, apply - should be two buttons "Advanced" and "Unblock".
  3. Click in the "Unblock" Button.
Coordinator
Jan 17, 2013 at 8:13 AM

I'm glad you sorted out the issue and grateful for the helpful community surrounding this project! :)

I'm taking note of this particular solution next time this problem comes up. So far it has been the most long standing issue with no clear solution.

Jan 17, 2013 at 8:18 AM

you are welcome :) I already started to write my own tilemap engine, but I thought I give it yet another try.

could you please add it to the tutorial?

I should be step 0 to unblock the dlls and mark as important cause Visual Express (and maybe also the other version) don't even hint that there could be a security problem?
Furthermore a small hint a the solution folder creation would be nice that that feature is not supported in express, but doesn't really matter. Less confusion, more comfort, smoother process.

Jan 17, 2013 at 4:05 PM

I agree, with gladius. This fixed my issue as well and should be added to the tutorials. Sorry, I didn't post my solution up. 

Coordinator
Jan 17, 2013 at 7:23 PM

Ok, it's in the documentation now.