Basic question about the tIDE tutorial.

May 26, 2011 at 10:20 AM

Hello world.  So I'm following this tutorial: http://tide.codeplex.com/wikipage?title=xTile%20Engine%20Tutorial%20for%20Game%20Studio%20%2f%20XNA%204.0&referringTitle=Documentation

(by the way, I lack the ability to add SOlution Folders as I only have 2010 Visual Studio Express, but I'll ask about that another time)

Number 6 states the following:

"Ensure that the map file's Content Importer and Content Processor properties are set respectively to tIDE Map Importer and tIDE Map Processor"

And I don't know how to add the tIDE items to the list of Content Processors and Importers.  I check their lists and get a series of XNA framework items.  Anyone know how to add the tIDE items to those lists?  Thanks for reading.

May 26, 2011 at 1:43 PM

Make sure you're referencing the pipeline assembly (xTile.Pipeline.dll) from the Content project, not the main game project.

As for solution folders, I don't think you strictly need them, but I would suggest at least creating the underlying directories within the solution and project folders. It's really a matter of organisation. I like to add external assemblies as project or solution items so I can include them in source control.

May 27, 2011 at 10:35 AM

But xTile.Pipeline.dll is referenced from the Content project; xTile.dll is the one in the main game project.  I can provide an image as proof, or any code should need be.

May 27, 2011 at 10:02 PM

That was my stock response :)

It could be due to some other factor of course.. have you tried going through the tutorial again with a new project?

May 28, 2011 at 11:01 AM
Edited May 28, 2011 at 11:03 AM

I fired up a new project and the same thing happened.  Maybe I didn't install it properly.

I continued with the tutorial anyway, and when I got to the last step (compile and run it), and unhandled exception error is generated - file not found.  I didn't think I'd have that problem.

I might be mistaken when I said I didn't have xTile.Pipeline.dll in the main project; because I can't have a solution folder, I just made a folder in the main game project for the actual xTile.dll and xTile.Pipeline files (this was a workaround for steps 2 and 3 in the tutorial).

Jun 12, 2011 at 4:54 AM

Hey guys,

 

I am having the same issue.   tIDE Map Importer and tIDE Map Processor not available options in VS2010.  Any and all guidance regarding this is highly appreciated.

 

Windows 7 Enterprise

Visual Studio 2010 Ultimate

Game Studio 4.0

Jun 13, 2011 at 10:13 PM

Seeing that this seems to be a common problem, I'm thinking it might be a good idea to set up a downloadable solution to use as a template.

Jul 2, 2011 at 7:05 PM

I am getting this problem too, checked, double checked, triple checked the references.  Tried locating the dlls in various different locations (using Express so cant use Solution folders)

I have:

Microsoft Visual Studio 2010Version WPDTRTMRel - 30319.174Microsoft .NET FrameworkVersion 4.0.30319 RTMRel
Installed Version: PD Express
Microsoft Visual C# 2010   02053-169-2504541-70811Microsoft Visual C# 2010
Microsoft Windows Phone Developer Tools - ENU   02053-169-2504541-70811Microsoft Windows Phone Developer Tools - ENU
Hotfix for Microsoft Windows Phone Developer Tools - ENU (KB2486994)   KB2486994This hotfix is for Microsoft Windows Phone Developer Tools - ENU.If you later install a more recent service pack, this hotfix will be uninstalled automatically.For more information, visit http://support.microsoft.com/kb/2486994.
Microsoft XNA Game Studio   4.0Microsoft XNA Game Studio 4.0Build 4.0.20823.0

OS is Windows 7 Home Premium x64.

Jul 3, 2011 at 12:31 AM

For the time being, can you try downloading the source from http://tide.codeplex.com/SourceControl/list/changesets# and opening it in VS 2010? You should hopefully be able to compile it and run the PC Demo project from within the solution.

Jul 3, 2011 at 9:45 PM

I downloaded the source (from 76082) and built it (had to remove the strong naming as it couldn't load the pfx files).  I took the two dlls and copied them into my solution and it worked fine :) .