Xbox File not Found

Apr 7, 2012 at 4:57 AM

ok, i have done everything i can think of to fix this, but when trying to load the map, of the tutorial files, and basically i get "file not found: Maps\Map01"

 

trying to compile the tutorial for use on the xbox, but i get this error every time

Apr 8, 2012 at 3:07 PM

I have the same problem with Windows Phone 7 and XNA ... that's awkard

Coordinator
Apr 8, 2012 at 8:38 PM

Have you tried the setting up an XNA PC game project? Perhaps it's a platform-related issue.

Apr 8, 2012 at 9:48 PM
Edited Apr 9, 2012 at 3:06 AM

Microsoft.Xna.Framework.Content.ContentLoadException was unhandled
  Message=Error loading "Maps\Map01". File not found.
  Source=Microsoft.Xna.Framework
  StackTrace:
       at Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
       at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
       at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
       at WindowsGame1.Game1.LoadContent() in C:\Users\user\Documents\Visual Studio 2010\Projects\WindowsGame1\WindowsGame1\WindowsGame1\Game1.cs:line 77
       at Microsoft.Xna.Framework.Game.Initialize()
       at WindowsGame1.Game1.Initialize() in C:\Users\user\Documents\Visual Studio 2010\Projects\WindowsGame1\WindowsGame1\WindowsGame1\Game1.cs:line 48
       at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
       at Microsoft.Xna.Framework.Game.Run()
       at WindowsGame1.Program.Main(String[] args) in c:\users\user\documents\visual studio 2010\Projects\WindowsGame1\WindowsGame1\WindowsGame1\Program.cs:line 15
  InnerException: System.IO.FileNotFoundException
       Message=Error loading "Content\Maps\Map01.xnb". File not found.
       Source=Microsoft.Xna.Framework
       StackTrace:
            at Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
            at Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
       InnerException: 

Coordinator
Apr 9, 2012 at 11:25 AM

It looks like it is failing at the point where it tries to load in the map in XNB format at initialisation. Can you verify if the XNB files are being generated within the Release/Debug directory?

Apr 9, 2012 at 1:34 PM

ok, it wasnt making the map file, i had to set build option to Compile, also i got it working on my xbox, i had to add in both the xbox  xtile.dll and the windows xtile.dll, in separate folders, and i have the xbox xtile.dll file referenced in the main game solution, i can zip up both my solutions so you can see

Coordinator
Apr 9, 2012 at 1:45 PM

I believe that if you create a PC or WP7 copy of your Xbox project (or all other combinations in vice versa), you can change the assembly references to point to the correct implementation i.e. use xTile DLL for Xbox, PC or WP7 as applicable.

Anyhow, I'm glad you sorted it out.

Apr 9, 2012 at 2:25 PM
ya, i made a new project for pc, and it worked perfectly fine with the pc xtile.dll, but when i made a new xbox project, i needed toe xbox xtile.dll, and the pc xtile.dll for it to work properly (with the pc xtile.dll referenced)

On Mon, Apr 9, 2012 at 9:45 AM, colinvella <notifications@codeplex.com> wrote:

From: colinvella

I believe that if you create a PC or WP7 copy of your Xbox project (or all other combinations in vice versa), you can change the assembly references to point to the correct implementation i.e. use xTile DLL for Xbox, PC or WP7 as applicable.

Anyhow, I'm glad you sorted it out.

Read the full discussion online.

To add a post to this discussion, reply to this email (tIDE@discussions.codeplex.com)

To start a new discussion for this project, email tIDE@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Jul 21, 2012 at 9:27 AM

Hi,

I'm now having this issue.  I had the map set to not build and naturally it said it couldn't find it, but if I set it to compile then I get;

Error	1	Building content threw Exception: Unable to load map with file path 'c:\users\dan\documents\visual studio 2010\Projects\xtiletestingx360\xtiletestingx360\xtiletestingx360Content\Map01.tide'
   at xTile.Format.FormatManager.LoadMap(String filePath)
   at xTile.Pipeline.TideImporter.Import(String filename, ContentImporterContext contentImporterContext)
   at Microsoft.Xna.Framework.Content.Pipeline.ContentImporter`1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetDirectly(BuildItem item, String importerName)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.RunTheBuild()
   at Microsoft.Xna.Framework.Content.Pipeline.Tasks.BuildContent.RemoteProxy.RunTheBuild(BuildCoordinatorSettings settings, TimestampCache timestampCache, ITaskItem[] sourceAssets, String[]& outputContent, String[]& rebuiltContent, String[]& intermediates, Dictionary`2& dependencyTimestamps, KeyValuePair`2[]& warnings)
	Inner exception: NotSupportedException: Specified method is not supported.
	   at xTile.Format.TideFormat.Load(Stream stream)
	   at xTile.Format.FormatManager.LoadMap(String filePath)	c:\users\dan\documents\visual studio 2010\Projects\xtiletestingx360\xtiletestingx360\xtiletestingx360Content\Map01.tide	xtiletestingx360

It doesn't look like anything was built in the debug files apart from the application.. I have tried with the PC dll and the xbox dll and it just won't compile.  The project does compile with the dlls referenced but without the map file in.

 

Thanks

Dan.

Jul 21, 2012 at 9:59 AM

Ok, I got that fixed now I'm just getting:

 

Error 1 Error loading pipeline assembly "xTile.Pipeline, Version=2.0.5.0, Culture=neutral, PublicKeyToken=null". xtiletestingx360

 

Dan.

Jul 21, 2012 at 10:04 AM

lol, so working on this example I put the xtile in its own folder and the pipeline dll outside, if I move the pipeline in with the xtile dll then I get the same error again... *crys* lol