tIDE v2.0.1 Released

Mar 9, 2011 at 7:35 AM
Edited Mar 9, 2011 at 7:39 AM

Version 2.0.1 introduces a new binary file format (.tbin) that is more compact than the XML format. The new binary format is now used internally by the XNA content pipeline processor for tIDE maps. Besides making the XNB map files more compact, this also sidesteps the issue of missing XML API functionality which broke the Xbox 360 engine release on version 2.0.0 due to migration to XNA 4.0. The releases have also been tested extensively on X360 and WP7 and some related issues have been solved. Further, the Demo now supports touch-enabled displays thanks to the new touch screen functionality in XNA 4.0.  

tIDE v2.0.1 MSI Installer

xTile v2.0.1 Engine for PC, X360 and WP7

xTile Demo v2.0.1 for PC

New Features

  • Added new tIDE compact binary file format with extension .tbin
  • Added support for Windows Phone 7
  • Added new tIDE compact binary file format with extension .tbin
  • Modified content pipeline processor code to internally use tbin instead of tide to avoid cross-platform issues (partial XML API on X360 and WP7)
  • Added Rectangle constructor that accepts integer parameters for convenience
  • Implemented touch-screen support for touch-enabled displays (also applicable to WP7)
  • Added .tbin file association to the tIDE MSI installer
  • Tested and solved engine issues on Xbox 360 and Windows Phone 7
Mar 24, 2011 at 5:50 PM



This is a really exciting project you are working on! I was wondering if you could provide some insight on this problem: The tIDE Map Importer and tIDE Map Processor are not available as options under Content Importer / Processor after following step 5 of the tutorial.  I'm using Visual Studio 2010 Pro, XNA 4.0 (Windows game project),  xTile.dll is referenced under game references and xTile.Pipeline.dll is referenced under game (content). Any help is much appreciated.


Thank you

Mar 26, 2011 at 6:11 PM


Thanks for your interest in this project and I hope you'll find it useful. Would you please try completing up to step 7 and see if the content pipeline processor compiles the maps? Make sure that xTile.Pipeline.dll is referenced as a normal assembly reference under the content project (Game Studio 4.0 will name this as WindowsGame1Content by default). You should not put it as an assembly reference or content reference under the main project itself (named WindowsGame1 by default).

If you still have issues, you can set up a simple project and send it over for me to look at.

Hope that helps