Where am I going wrong here. Cant even build the sample content in gs4

Oct 7, 2011 at 7:00 AM
Edited Oct 7, 2011 at 8:54 AM

So I created a new project.. Called xTileTest.. its the default project.. added the folders and added the appropriate references.. the content importer and everything looks set right.. Redownloaded both the editor and xtile.. Im using the sample map and files.. 

But no matter what I do, I always get an exception and cant build.. 

I zipped up the solution and it can be downloaded here:   http://www.squigglyfrog.com/xTileTest.rar

That path is correct, and the file is exactly right there.. 

any thoughts here? 



Error	1	Building content threw Exception: Unable to load map with file path 'C:\_CSharp\_phone\xTileTest\xTileTest\xTileTestContent\Maps\Map01.tide'
   at xTile.Format.FormatManager.LoadMap(String filePath)
   at xTile.Pipeline.TideImporter.Import(String filename, ContentImporterContext contentImporterContext)
   at Microsoft.Xna.Framework.Content.Pipeline.ContentImporter`1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetDirectly(BuildItem item, String importerName)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.RunTheBuild()
   at Microsoft.Xna.Framework.Content.Pipeline.Tasks.BuildContent.RemoteProxy.RunTheBuild(BuildCoordinatorSettings settings, TimestampCache timestampCache, ITaskItem[] sourceAssets, 
String[]& outputContent, String[]& rebuiltContent, String[]& intermediates, Dictionary`2& dependencyTimestamps, KeyValuePair`2[]& warnings)

	Inner exception: NotSupportedException: Specified method is not supported.
	   at xTile.Format.TideFormat.Load(Stream stream)
	   at xTile.Format.FormatManager.LoadMap(String filePath)	C:\_CSharp\_phone\xTileTest\xTileTest\xTileTestContent\Maps\Map01.tide	xTileTest
Oct 7, 2011 at 8:36 AM

I tried compiling your solution and I get the same problem. The core exception is that a non-existent method is being called and I suspect this is because you created the Phone project for 7.1 and not 7.0. Could you try recreating the project as a Windows Phone 7.0 project? I think there is also some way to edit the project file to make it look like 7.0 but it's probably simpler to just recreate it.

I will eventually upgrade the xTile engine to work with WP 7.1.

Oct 7, 2011 at 8:37 AM

P.S. When you create a Phone project you should be given the option between choosing 7.0 and 7.1. If you create a 7.0 project you then get the option of upgrading to 7.1 at any time but you cannot do the reverse.

Oct 7, 2011 at 8:39 AM

Doh... I hadn't even thought of that... Let me give it a shot.. BTW, appreciate the FAST response!

Oct 7, 2011 at 8:53 AM

No such luck.. same exact error.. To be sure, i created 2 more projects, just so i could make sure i selected 7.0 instead of 7.1   ... This is on the vis studio 7.1 RC... so Im not sure what all is going on here.. I do notice when looking at the app manifest even on a 7.0 game, it shows 7,1... 

Oct 7, 2011 at 12:16 PM

I'm not sure what's the problem at this stage, I'll have to look into when I get a chance. I wonder if anyone else has this issue...

Oct 16, 2011 at 4:56 PM

I have the same problem, I can't import *.tide maps into a WinPhone 7.1 project.

As a workaround, I'm using the *.tbin format, which seems to work fine.

Oct 16, 2011 at 8:51 PM

Sure enough.. Change it to save in tBin format, and it compiles perfectly.. Hadnt even tried that since it wasnt a major deal to me anyways, but.. nice to know that worked!

Oct 17, 2011 at 10:19 AM

Glad to hear you found a workaround. I have yet to update the XTile project itself to 7.1 but I suspect it may be due to a change in API.